Back to overview
Degraded

Elevated API latency

Apr 1, 2026 at 3:54pm UTC
Affected services
App
API

Resolved
Apr 1, 2026 at 4:29pm UTC

The issue has been identified and is now fully resolved. We are implementing the necessary actions and guardrails to prevent this from happening again.

Created
Apr 1, 2026 at 3:54pm UTC

We experienced increased API latency, caused by unexpected usage of a specific API endpoint