Back to overview
Degraded
Degraded performance on browser app
May 28, 2026 at 9:03am UTC
Affected services
App
Resolved
May 28, 2026 at 10:01am UTC
The fix has been rolled out and the app should be back to normal. The team continues to monitor the systems.
Affected services
Updated
May 28, 2026 at 9:39am UTC
We have identified a potential cause and are currently rolling out mitigation changes
Affected services
Created
May 28, 2026 at 9:03am UTC
We are currently investigating an incident impacting app latency. The UI is partially unavailable for some customers.
API and event ingestion is not impacted.
Our teams are actively working to identify the root cause.
Affected services